# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((.|[\r\n])+?)[a-z]\)"
test_str = ("Assinale a<br />\n"
"alternativa correta:<br />\n"
"<br />\n"
"a)São livros obrigatórios para todas as serventias extrajudiciais do Estado do Ceará: livro de registro de inspeção e correição; livro de depósito de firma por autenticidade e livro de depósito prévio de emolumentos.<br />\n"
"b)A procuração para fins de procedimento de habilitação de casamento pode também ser outorgada por instrumento particular.<br />\n"
"c)No Estado do Ceará as serventias extrajudiciais devem observar sempre o tempo máximo de espera de 30 minutos para atendimento dos usuários. Qualquer alteração de endereço da sede da serventia depende de autorização do Juiz Corregedor Permanente e comunicação ao Corregedor Geral.<br />\n"
"d)Conforme entendimento do STF os emolumentos possuem natureza tributária, entretanto, não são taxas e sim espécie distinta e singular àquelas previstas na Constituição e no Código Tributário Nacional. Por esta razão, podem ser livremente reduzidos ou dispensados pelo tabelião ou registrador no exercício de sua atividade privada.<br />\n"
"e)Conforme entendimento do STF os emolumentos possuem natureza tributária, entretanto, não são taxas e sim espécie distinta e singular àquelas previstas na Constituição e no Código Tributário Nacional. Por esta razão, podem ser livremente reduzidos ou dispensados pelo tabelião ou registrador no exercício de sua atividade privada.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.