// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((.|[\r\n])+?)[a-z]\)").unwrap();
let string = "Assinale a<br />
alternativa correta:<br />
<br />
a)São livros obrigatórios para todas as serventias extrajudiciais do Estado do Ceará: livro de registro de inspeção e correição; livro de depósito de firma por autenticidade e livro de depósito prévio de emolumentos.<br />
b)A procuração para fins de procedimento de habilitação de casamento pode também ser outorgada por instrumento particular.<br />
c)No Estado do Ceará as serventias extrajudiciais devem observar sempre o tempo máximo de espera de 30 minutos para atendimento dos usuários. Qualquer alteração de endereço da sede da serventia depende de autorização do Juiz Corregedor Permanente e comunicação ao Corregedor Geral.<br />
d)Conforme entendimento do STF os emolumentos possuem natureza tributária, entretanto, não são taxas e sim espécie distinta e singular àquelas previstas na Constituição e no Código Tributário Nacional. Por esta razão, podem ser livremente reduzidos ou dispensados pelo tabelião ou registrador no exercício de sua atividade privada.<br />
e)Conforme entendimento do STF os emolumentos possuem natureza tributária, entretanto, não são taxas e sim espécie distinta e singular àquelas previstas na Constituição e no Código Tributário Nacional. Por esta razão, podem ser livremente reduzidos ou dispensados pelo tabelião ou registrador no exercício de sua atividade privada.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}