using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<CI_V2>[^;]*);(?<CI_1>[^;\""]*);(?<CI_2>[^;\""]*);*(?<CI_3>[^;\""]*);*(?<CI_4>[^;\""]*);(?<CI_5>[^\""]*)";
string input = @"""CI"": ""V2;Y;Windows;srv048;LogicalDisk;C:"",
""CI"": ""V2;Y;Linx;srv048"",
""CI"": ""V2;LX;apple;rose;server"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}