import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<CI_V2>[^;]*);(?<CI_1>[^;\\\"]*);(?<CI_2>[^;\\\"]*);*(?<CI_3>[^;\\\"]*);*(?<CI_4>[^;\\\"]*);(?<CI_5>[^\\\"]*)";
final String string = "\"CI\": \"V2;Y;Windows;srv048;LogicalDisk;C:\",\n"
+ "\"CI\": \"V2;Y;Linx;srv048\",\n"
+ "\"CI\": \"V2;LX;apple;rose;server\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}