using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"profile\d+\.name=(.+)";
string input = @"profile2.name=share2
profile8.name=share8
profile4.name=shareSSH
profile9.name=share9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}