#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\/[1-9][0-9]$"
Local $sString = "2225/35" & @CRLF & _
"2/25" & @CRLF & _
"123/12" & @CRLF & _
"4321/56" & @CRLF & _
"/22" & @CRLF & _
"0/00" & @CRLF & _
"0145/36" & @CRLF & _
"1234" & @CRLF & _
"5215" & @CRLF & _
"2036" & @CRLF & _
"" & @CRLF & _
"256314" & @CRLF & _
"123456" & @CRLF & _
"654321" & @CRLF & _
"102365" & @CRLF & _
"" & @CRLF & _
"123456" & @CRLF & _
"19" & @CRLF & _
"222222/12" & @CRLF & _
"256314/21" & @CRLF & _
"" & @CRLF & _
"256314/21" & @CRLF & _
"06314/21" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"52634125/25" & @CRLF & _
"025636/65" & @CRLF & _
"" & @CRLF & _
"025253" & @CRLF & _
"253641" & @CRLF & _
"" & @CRLF & _
"19" & @CRLF & _
"01" & @CRLF & _
"" & @CRLF & _
"123" & @CRLF & _
"032" & @CRLF & _
"" & @CRLF & _
"1234" & @CRLF & _
"0325" & @CRLF & _
"123456" & @CRLF & _
"036254" & @CRLF & _
"" & @CRLF & _
"965236" & @CRLF & _
"095325" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")