const regex = /^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\/[1-9][0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9])\\\/[1-9][0-9]$', 'gm')
const str = `2225/35
2/25
123/12
4321/56
/22
0/00
0145/36
1234
5215
2036
256314
123456
654321
102365
123456
19
222222/12
256314/21
256314/21
06314/21
52634125/25
025636/65
025253
253641
19
01
123
032
1234
0325
123456
036254
965236
095325
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}