package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d+(?:\.\d+){2}$`)
var str = `11111111.11111111.1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}