use strict;
my $str = 'Select Count(distinct c.requestId) FROM Abc1Value c WHERE 1=1 and c.templateName is NULL "
+" AND (c.quickStatus IS NULL OR c.quickStatus = \'S\') "
+ " AND (c.sCode=\'MYCODE\' OR exists (SELECT b.dseaReqId FROM drstSShareValue b WHERE b.dseaReqId=c.requestId and b.sCode=\'MYCODE\')) "
+ " AND (upper(c.licenseNo) like \'%"12548"%\' or upper(c.docLicenseNo) like \'%""%\' or upper(c.uncontrolledLicense) like \'%""%\' or upper(c.nonAuthNo) like \'%""%\' or upper(c.reAuthNo) like \'%""%\') "
+ " and upper(c.grantedByCtryCode) like \'%US%\'';
my $regex = qr/(?i)like\s+'%.*?%'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}