# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)like\s+'%.*?%'"
test_str = ("Select Count(distinct c.requestId) FROM Abc1Value c WHERE 1=1 and c.templateName is NULL \"\n"
" +\" AND (c.quickStatus IS NULL OR c.quickStatus = 'S') \"\n"
" + \" AND (c.sCode='MYCODE' OR exists (SELECT b.dseaReqId FROM drstSShareValue b WHERE b.dseaReqId=c.requestId and b.sCode='MYCODE')) \"\n"
" + \" AND (upper(c.licenseNo) like '%\"12548\"%' or upper(c.docLicenseNo) like '%\"\"%' or upper(c.uncontrolledLicense) like '%\"\"%' or upper(c.nonAuthNo) like '%\"\"%' or upper(c.reAuthNo) like '%\"\"%') \"\n"
" + \" and upper(c.grantedByCtryCode) like '%US%'")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.