package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\d+)d)?((\d+)h)?((\d+)(?:min|m))?((\d+)s)?$`)
var str = `4d28h12m3s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}