$re = '/^((\d+)d)?((\d+)h)?((\d+)(?:min|m))?((\d+)s)?$/m';
$str = '4d28h12m3s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);