# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<=<|<\\/)|(?<= ))[A-Za-z0-9]+:| xmlns(:[A-Za-z0-9]+)?=".*?"//g;t' <<< "<?xml version=\"1.0\" encoding=\"utf-16\"?>
<ArrayOfInserts xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">
<insert>
<offer xmlns=\"http://schema.peters.com/doc_353/1/Types\">0174587</offer>
<type2 xmlns=\"http://schema.peters.com/doc_353/1/Types\">014717</type2>
<supplier xmlns=\"http://schema.peters.com/doc_353/1/Types\">019172</supplier>
<id_frame xmlns=\"http://schema.peters.com/doc_353/1/Types\" />
<type3 xmlns=\"http://schema.peters.com/doc_353/1/Types\">
<type2 />
<main>false</main>
</type3>
<status xmlns=\"http://schema.peters.com/doc_353/1/Types\">Some state</status>
</insert>
</ArrayOfInserts>"