import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=<|<\\/)|(?<= ))[A-Za-z0-9]+:| xmlns(:[A-Za-z0-9]+)?=\".*?\"";
final String string = "<?xml version=\"1.0\" encoding=\"utf-16\"?>\n"
+ "<ArrayOfInserts xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
+ " <insert>\n"
+ " <offer xmlns=\"http://schema.peters.com/doc_353/1/Types\">0174587</offer>\n"
+ " <type2 xmlns=\"http://schema.peters.com/doc_353/1/Types\">014717</type2>\n"
+ " <supplier xmlns=\"http://schema.peters.com/doc_353/1/Types\">019172</supplier>\n"
+ " <id_frame xmlns=\"http://schema.peters.com/doc_353/1/Types\" />\n"
+ " <type3 xmlns=\"http://schema.peters.com/doc_353/1/Types\">\n"
+ " <type2 />\n"
+ " <main>false</main>\n"
+ " </type3>\n"
+ " <status xmlns=\"http://schema.peters.com/doc_353/1/Types\">Some state</status>\n"
+ " </insert>\n"
+ "</ArrayOfInserts>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}