package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^:]*:(\d+)`)
var str = `asdasdasd\\size\x22:22
23232d:123123123
2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}