const regex = new RegExp('^[^:]*:(\\d+)', '')
const str = `asdasdasd\\\\size\\x22:22
23232d:123123123
2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}