use strict;
my $str = 'jul20
october2
December9
nov10
jun49
August09
Jan12
Sep11
Sept12
September14
';
my $regex = qr/([Jj]an(uary)?|[Ff]eb(ruary)?|[Mm]ar(ch)?|[Aa]pr(il)?|[Mm]ay|[Jj]un(e)?|[Jj]ul(y)?|[Aa]ug(ust)?|[Ss]ep(t(ember)?)?|[Oo]ct(ober)?|[Nn]ov(ember)?|[Dd]ec(ember)?)((0[1-9])|([12][0-9])|(3[01])|[1-9]){1}
/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}