import re
regex = re.compile((r"([Jj]an(uary)?|[Ff]eb(ruary)?|[Mm]ar(ch)?|[Aa]pr(il)?|[Mm]ay|[Jj]un(e)?|[Jj]ul(y)?|[Aa]ug(ust)?|[Ss]ep(t(ember)?)?|[Oo]ct(ober)?|[Nn]ov(ember)?|[Dd]ec(ember)?)((0[1-9])|([12][0-9])|(3[01])|[1-9]){1}\n"))
test_str = ("jul20\n"
"october2\n"
"December9\n"
"nov10\n"
"jun49\n"
"August09\n"
"Jan12\n"
"Sep11\n"
"Sept12\n"
"September14\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")