using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b\w+=\()[^)]+(?=\))";
string input = @"title=(example1) caption=(example2) button=(example3) price=(example4) off=(example5)
lorem ipsum this is ignored magic=(happens) here! :)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}