re = /(?<=\b\w+=\()[^)]+(?=\))/m
str = 'title=(example1) caption=(example2) button=(example3) price=(example4) off=(example5)
lorem ipsum this is ignored magic=(happens) here! :)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end