$re = '/^([a-zA-Z]{2,}\s[a-zA-Z]{1,}\'?-?[a-zA-Z]{2,}\s?([a-zA-Z]{1,})?)/m';
$str = 'Al Bundy
Jean-Claude Van Damme
Lev Nikolayevich Tolstoy
Лев Николаевич Толстой
Bruce Lee
李小龍
Döner
López
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);