re = /^([a-zA-Z]{2,}\s[a-zA-Z]{1,}'?-?[a-zA-Z]{2,}\s?([a-zA-Z]{1,})?)/m
str = 'Al Bundy
Jean-Claude Van Damme
Lev Nikolayevich Tolstoy
Лев Николаевич Толстой
Bruce Lee
李小龍
Döner
López
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end