use strict;
my $str = 'Frederick Clarke
Birth
6 Feb 1871
Death
7 Nov 1952 (aged 81)
Sheffield
Burial
Crookes Cemetery
Sheffield, Metropolitan Borough of Sheffield, South Yorkshire, England
Show MapGPS-Latitude: 53.384024, Longitude: -1.515043
Plot
MM 7848
Memorial ID
237065233';
my $regex = qr/^(?<forename>.+?)\s(?<surname>\w+)\nBirth\n(?:(?<birth_day>(\d{1,2}|unknown))\s(?<birth_month>\w{3})\s(?<birth_year>\d{4})|\bunknown\b)\n(?<birth_location>.+?)\nDeath\n(?:(?<death_day>(\d{1,2}|unknown))\s(?<death_month>\w{3})\s(?<death_year>\d{4})(?:\s*\(aged\s*(?<age>\d+)\))?|unknown)\n(?<death_location>.+?)\nBurial\n(?<cemetery_name>.+?)\n(?<cemetery_location>.+?)\n(?:Show MapGPS-Latitude:\s*(?<latitude>-?\d+\.\d+),\s*Longitude:\s*(?<longitude>-?\d+\.\d+))?\n?(?:Plot\n(?<plot>.+?)\n?)?Memorial ID\n(?<memorial_id>\d+)
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}