#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\W)(?:youtube(?:-nocookie)?\.com/(?:.*[?&]v=|v/|e(?:mbed)?/|[^/]+/.+/)|youtu\.be/)([\w-]+)"
Local $sString = "youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=feedrec_grec_index" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk#t=0m10s" & @CRLF & _
"https://www.youtube.com/?feature=player_embedded&v=DFYRQ_zQ-gk" & @CRLF & _
"https://www.youtube.com/watch?feature=player_embedded&v=DFYRQ_zQ-gk" & @CRLF & _
"https://www.youtube.com/UCucW7UIJh8FHbv2O0jW8skw?v=DFYRQ_zQ-gk#t=0m10s" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://www.youtube.com/e/DFYRQ_zQ-gk?fs=1&hl=en_US&rel=0" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk?rel=0" & @CRLF & _
"https://www.youtube.com/user/UCucW7UIJh8FHbv2O0jW8skw#p/u/11/DFYRQ_zQ-gk?rel=0" & @CRLF & _
"https://www.youtube.com/UCucW7UIJh8FHbv2O0jW8skw#p/c/54B8C800269D7C1B/0/DFYRQ_zQ-gk?rel=0" & @CRLF & _
"" & @CRLF & _
"m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk?t=2s" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk?list=PLelYX5BVrtO0sWvnTSdvot21pjlKTNVeU" & @CRLF & _
"" & @CRLF & _
"https://youtube-nocookie.com/watch?v=DFYRQ_zQ-gk?t=2s" & @CRLF & _
"" & @CRLF & _
"<iframe width="480" height="270" src="https://www.youtube.com/embed/DFYRQ_zQ-gk?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>" & @CRLF & _
"" & @CRLF & _
"in text youtube.com/watch?v=DFYRQ_zQ-gk in text" & @CRLF & _
"" & @CRLF & _
"DFYRQ_zQ-gk" & @CRLF & _
"/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://www.youtubee.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://notyoutube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")