const regex = new RegExp('(?:^|\\W)(?:youtube(?:-nocookie)?\\.com/(?:.*[?&]v=|v/|e(?:mbed)?/|[^/]+/.+/)|youtu\\.be/)([\\w-]+)', 'mg')
const str = `youtube.com/watch?v=DFYRQ_zQ-gk
www.youtube.com/watch?v=DFYRQ_zQ-gk
https://youtube.com/watch?v=DFYRQ_zQ-gk
https://www.youtube.com/watch?v=DFYRQ_zQ-gk
https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=feedrec_grec_index
https://www.youtube.com/watch?v=DFYRQ_zQ-gk#t=0m10s
https://www.youtube.com/?feature=player_embedded&v=DFYRQ_zQ-gk
https://www.youtube.com/watch?feature=player_embedded&v=DFYRQ_zQ-gk
https://www.youtube.com/UCucW7UIJh8FHbv2O0jW8skw?v=DFYRQ_zQ-gk#t=0m10s
https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US&rel=0
https://www.youtube.com/e/DFYRQ_zQ-gk?fs=1&hl=en_US&rel=0
https://www.youtube.com/embed/DFYRQ_zQ-gk?rel=0
https://www.youtube.com/user/UCucW7UIJh8FHbv2O0jW8skw#p/u/11/DFYRQ_zQ-gk?rel=0
https://www.youtube.com/UCucW7UIJh8FHbv2O0jW8skw#p/c/54B8C800269D7C1B/0/DFYRQ_zQ-gk?rel=0
m.youtube.com/watch?v=DFYRQ_zQ-gk
//m.youtube.com/watch?v=DFYRQ_zQ-gk
https://m.youtube.com/watch?v=DFYRQ_zQ-gk
youtu.be/DFYRQ_zQ-gk
https://youtu.be/DFYRQ_zQ-gk
https://youtu.be/DFYRQ_zQ-gk?t=2s
https://youtu.be/DFYRQ_zQ-gk?list=PLelYX5BVrtO0sWvnTSdvot21pjlKTNVeU
https://youtube-nocookie.com/watch?v=DFYRQ_zQ-gk?t=2s
<iframe width="480" height="270" src="https://www.youtube.com/embed/DFYRQ_zQ-gk?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
in text youtube.com/watch?v=DFYRQ_zQ-gk in text
DFYRQ_zQ-gk
/watch?v=DFYRQ_zQ-gk
https://www.youtubee.com/watch?v=DFYRQ_zQ-gk
https://notyoutube.com/watch?v=DFYRQ_zQ-gk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}