$re = '/\d+(?:\.\d+)? x \d+(?:\.\d+)? /m';
$str = '1 photograph - b&w - 2.1 x 5.5 in.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);