re = /\d+(?:\.\d+)? x \d+(?:\.\d+)? /m
str = '1 photograph - b&w - 2.1 x 5.5 in.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end