# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Stable tag\: (\d+(?:\.\d+)*)$/3.0.13/gmi;t' <<< "Stable tag: 4.1.5.3
Stable tag: 11.0.5.3
Stable tag: 23.1.5.3
Stable tag: 13.0.1
Stable tag: 13.0
Stable tag: 2.0.1
Stable tag: 3.0.21.4.2
Stable tag: 3.0
Stable tag: 3.0.111.32
Stable tag: 1.0.1.3
Stable tag: 3
"