// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)Stable tag\: (\d+(?:\.\d+)*)$").unwrap();
let string = "Stable tag: 4.1.5.3
Stable tag: 11.0.5.3
Stable tag: 23.1.5.3
Stable tag: 13.0.1
Stable tag: 13.0
Stable tag: 2.0.1
Stable tag: 3.0.21.4.2
Stable tag: 3.0
Stable tag: 3.0.111.32
Stable tag: 1.0.1.3
Stable tag: 3
";
let substitution = "3.0.13";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}