$re = '/^((?:[^|]+\|){2})([^|]+\|[^|]{,2}(?=\|))/m';
$str = 'as234-H344423-dfX|dfer XXYUyu werg|1g|z4|sweDSgIKU|2017-SS0|123.45|YTf
as234-H3wer23-dZ|df3r Xa12yu wg|a1|2|sweDSgIKU|2017-SS0|123.45|YTf
as234-HJ123-HG|dfdf KHT werg|XXL|s45dtgIKU|2017-SS0|123.45|asUJY';
$subst = "\1\"\2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;