using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Hyperlink"" href="")((http)(.+?)(\""|').*?)";
string input = @"<td style=""vertical-align: top; width: 375px""><h1 id=""H_67e23f29-bb69-46eb-b15c"">00 - <a class=""Hyperlink"" href=""http://xxxx.xxxxxxx.com/Management/HyperlinkLoader.aspx?HyperlinkID=c64b7052-4229-4169-b8a2"" class=""Hyperlink"" onmouseover=""HyperlinkLoader.showTooltip(event,'c64b7052-4229-4169-b8a2')"" onclick=""HyperlinkLoader.followHyperlink(event,{'HyperlinkID':'c64b7052-4229-4169-b8a2','ReturnURL':''});return false"">Algemeen</a></h1></td>
<td style=""width: 292px; vertical-align: top; background-color: rgb(255, 255, 255); text-align: left""><a class=""Hyperlink"" href=""http://xxxx.xxxxxxx.com/Management/HyperlinkLoader.aspx?HyperlinkID=29517117-26ce-4004-88ed"" class=""Hyperlink"" onmouseover=""HyperlinkLoader.showTooltip(event,'29517117-26ce-4004-88ed')"" onclick=""HyperlinkLoader.followHyperlink(event,{'HyperlinkID':'29517117-26ce-4004-88ed','ReturnURL':''});return false"">Asbestbeheersplan</a></td>
<td style=""vertical-align: top; width: 375px""><h1 id=""H_f534b7b2-a8f5-41b0-9aa8"">01 - <a class=""Hyperlink"" href=""http://xxxx.xxxxxxx.com/Management/HyperlinkLoader.aspx?HyperlinkID=7af55197-d865-4cb2-bb9c"" class=""Hyperlink"" onmouseover=""HyperlinkLoader.showTooltip(event,'7af55197-d865-4cb2-bb9c')"" onclick=""HyperlinkLoader.followHyperlink(event,{'HyperlinkID':'7af55197-d865-4cb2-bb9c','ReturnURL':''});return false"">Voor werken geldende voorwaarden</a></h1></td>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}