use strict;
my $str = '<td style="vertical-align: top; width: 375px"><h1 id="H_67e23f29-bb69-46eb-b15c">00 - <a class="Hyperlink" href="http://xxxx.xxxxxxx.com/Management/HyperlinkLoader.aspx?HyperlinkID=c64b7052-4229-4169-b8a2" class="Hyperlink" onmouseover="HyperlinkLoader.showTooltip(event,\'c64b7052-4229-4169-b8a2\')" onclick="HyperlinkLoader.followHyperlink(event,{\'HyperlinkID\':\'c64b7052-4229-4169-b8a2\',\'ReturnURL\':\'\'});return false">Algemeen</a></h1></td>
<td style="width: 292px; vertical-align: top; background-color: rgb(255, 255, 255); text-align: left"><a class="Hyperlink" href="http://xxxx.xxxxxxx.com/Management/HyperlinkLoader.aspx?HyperlinkID=29517117-26ce-4004-88ed" class="Hyperlink" onmouseover="HyperlinkLoader.showTooltip(event,\'29517117-26ce-4004-88ed\')" onclick="HyperlinkLoader.followHyperlink(event,{\'HyperlinkID\':\'29517117-26ce-4004-88ed\',\'ReturnURL\':\'\'});return false">Asbestbeheersplan</a></td>
<td style="vertical-align: top; width: 375px"><h1 id="H_f534b7b2-a8f5-41b0-9aa8">01 - <a class="Hyperlink" href="http://xxxx.xxxxxxx.com/Management/HyperlinkLoader.aspx?HyperlinkID=7af55197-d865-4cb2-bb9c" class="Hyperlink" onmouseover="HyperlinkLoader.showTooltip(event,\'7af55197-d865-4cb2-bb9c\')" onclick="HyperlinkLoader.followHyperlink(event,{\'HyperlinkID\':\'7af55197-d865-4cb2-bb9c\',\'ReturnURL\':\'\'});return false">Voor werken geldende voorwaarden</a></h1></td>';
my $regex = qr/(?<=Hyperlink" href=")((http)(.+?)(\"|').*?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}