#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^\[([^][]*)]\s+(.*(?:\n(?!\[[^][]*]).*)*)"
Local $sString = "[key X] value" & @CRLF & _
"[key X] value value" & @CRLF & _
"[key X] value" & @CRLF & _
"value" & @CRLF & _
"value" & @CRLF & _
"value" & @CRLF & _
"[key ] value" & @CRLF & _
"[key ] ?" & @CRLF & _
"[key ] ?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")