import re
regex = re.compile(r"(?m)^\[([^][]*)]\s+(.*(?:\n(?!\[[^][]*]).*)*)", flags=re.MULTILINE)
test_str = ("[key X] value\n"
"[key X] value value\n"
"[key X] value\n"
"value\n"
"value\n"
"value\n"
"[key ] value\n"
"[key ] ?\n"
"[key ] ?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")