package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([a-zA-Z0-9-._]+)@[a-zA-Z0-9-]+(\.[a-zA-Z0-9]{2,})+\b`)
var str = `name.surname@gmail.com
anonymous123@yahoo.co.uk
my_email@outlook.co
johnsnow@gmail
anonymous123@...uk
myemail@outlook.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}