#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w]+);([\d]{2})-([\w]{3}|[\d]{2})-([\d]{4});([\d]{2}):([\d]{2}):([\d]{2});([\d]+);(?(?=[\w]*;)([\w]*);|)((?:([a-zA-Z0-9_@.#\/&+\(\)\-\\!$%^*=',.<>?{}\[\]`~:\| ]+)[ ]*[-][ ]*([\d]*);)+)([\d]+);"
Local $sString = "SGH;02-FEB-2017;02:02:02;200;buah -1;3;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")