package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w)(\w*)|([^\w\s])|\s`)
var str = `The pen is on the table.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}