$re = '/(\w)(\w*)|([^\w\s])|\s/m';
$str = 'The pen is on the table.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);