const regex = /\[((id|club)\d+)\|(.+?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[((id|club)\\d+)\\|(.+?)\\]', 'g')
const str = `Отдельное спасибо [id89083229|Ане], [id169355957|Лере], [id148334713|Маргарите], [id146667775|Насте В.] и [id137626852|Насте Н.], которые согласились сняться в этом видео!`;
const subst = `<span data-id="$1">$3</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);