$re = '/\[((id|club)\d+)\|(.+?)\]/';
$str = 'Отдельное спасибо [id89083229|Ане], [id169355957|Лере], [id148334713|Маргарите], [id146667775|Насте В.] и [id137626852|Насте Н.], которые согласились сняться в этом видео!';
$subst = "<span data-id=\"$1\">$3</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;