#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)--\[\[(?:\s|.)+?\]\]|^--.*"
Local $sString = "--[[" & @CRLF & _
" block" & @CRLF & _
"]]" & @CRLF & _
"" & @CRLF & _
"--[[" & @CRLF & _
" lua" & @CRLF & _
"]]" & @CRLF & _
"" & @CRLF & _
"--singleLine" & @CRLF & _
"" & @CRLF & _
"-- :D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")