re = /--\[\[(?:\s|.)+?\]\]|^--.*/m
str = '--[[
block
]]
--[[
lua
]]
--singleLine
-- :D'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end