import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!п?ос[л|к][а|о]р?бляе?т?ь?л?)\\w*бля\\w*|(\\w*бляд\\w*)|(\\w*ху[й|и|е|ё|я|]\\w*)|\\b(хули)\\b|([е|ё]{1,}пт[а|и|е|о]?\\b)|([до]\\w*[ё|е]б)|(пизд\\w*)|(пид[а|о|е]р\\w*)|(пид[е|а|о]р)|(пидр?[\\w]{1,}\\b)|(гандон\\w*)|\\b(?!нё)(\\w*[е|ё]б[а|о|и|н]\\w*)|(еб[е|ё|а|у|н]\\w*)|(\\w*еб[а]\\w*)|(\\w*[у|е|за]{1,2}[е|ё]б)|\\b(?!\\w)\\s(ёб)\\s";
final String string = "бля блять блядь блядина выблядок сракоблять сракоблядь оскарблять оскорблять блядосрака бляцкий блятский блядский блцк ослаблять ослабляет оскарбляет ослоблял ослаблял осбаляет оскарблять оскарблядь ослоблядь ослоблядит послаблять\n\n"
+ "хуй хуило хуйло хуево хуёво хуже хуев хуи хуевая хуёвая хуёвый хуятина хули хулио\n\n"
+ "ебать заебал уебок уебище уебан уёбан уёбок ёб нёбо гёрб захлёб уебался заебал уебал ебать ёпта ёпт епта епт епти ёпти ёпто ебучие еб ебнутый ебется ебётся долбаёб долбаеб ебал ёбнутый ебанат ебанклаус грёб в захлёб заебался \n\n"
+ "пизда пизданулся пиздец пиздос пиздатый пизд пиздюк \n\n"
+ "пидр пидор пидар пидер пидарас пидорас пидерас пидераст пидараст пидораст пидрила пидрило\n\n"
+ "гандон гандонина";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}