import re
regex = re.compile(r"\b(?!п?ос[л|к][а|о]р?бляе?т?ь?л?)\w*бля\w*|(\w*бляд\w*)|(\w*ху[й|и|е|ё|я|]\w*)|\b(хули)\b|([е|ё]{1,}пт[а|и|е|о]?\b)|([до]\w*[ё|е]б)|(пизд\w*)|(пид[а|о|е]р\w*)|(пид[е|а|о]р)|(пидр?[\w]{1,}\b)|(гандон\w*)|\b(?!нё)(\w*[е|ё]б[а|о|и|н]\w*)|(еб[е|ё|а|у|н]\w*)|(\w*еб[а]\w*)|(\w*[у|е|за]{1,2}[е|ё]б)|\b(?!\w)\s(ёб)\s", flags=re.DOTALL | re.IGNORECASE | re.MULTILINE | re.UNICODE)
test_str = ("бля блять блядь блядина выблядок сракоблять сракоблядь оскарблять оскорблять блядосрака бляцкий блятский блядский блцк ослаблять ослабляет оскарбляет ослоблял ослаблял осбаляет оскарблять оскарблядь ослоблядь ослоблядит послаблять\n\n"
"хуй хуило хуйло хуево хуёво хуже хуев хуи хуевая хуёвая хуёвый хуятина хули хулио\n\n"
"ебать заебал уебок уебище уебан уёбан уёбок ёб нёбо гёрб захлёб уебался заебал уебал ебать ёпта ёпт епта епт епти ёпти ёпто ебучие еб ебнутый ебется ебётся долбаёб долбаеб ебал ёбнутый ебанат ебанклаус грёб в захлёб заебался \n\n"
"пизда пизданулся пиздец пиздос пиздатый пизд пиздюк \n\n"
"пидр пидор пидар пидер пидарас пидорас пидерас пидераст пидараст пидораст пидрила пидрило\n\n"
"гандон гандонина")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")