package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\x23[^\x2c]+)\x2c[[:space:]]start[[:space:]][[:digit:]]{4}\x2d[[:digit:]]{2}\x2d[[:digit:]]{2}[[:space:]]([^[:space:]]+)[[:space:]][^\x2c]+\x2c[^\x2c]+\x2c[[:space:]](captureme)`)
var str = `Message #1243669, start 2018-12-17 16:32:50 CET, duration 20, captureme`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}