re = /(\x23[^\x2c]+)\x2c[[:space:]]start[[:space:]][[:digit:]]{4}\x2d[[:digit:]]{2}\x2d[[:digit:]]{2}[[:space:]]([^[:space:]]+)[[:space:]][^\x2c]+\x2c[^\x2c]+\x2c[[:space:]](captureme)/m
str = 'Message #1243669, start 2018-12-17 16:32:50 CET, duration 20, captureme'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end