using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SAMPLE_SIGN([\S\s]+)(?=SAMPLE_SIGN)";
string input = @"some program code SAMPLE_SIGN text inside the
sample SAMPLE_SIGN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}