$re = '/SAMPLE_SIGN([\S\s]+)(?=SAMPLE_SIGN)/m';
$str = 'some program code SAMPLE_SIGN text inside the
sample SAMPLE_SIGN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);