import re
regex = re.compile(r"^\d+\.\d+(?={[^{}]*}|\w+\\)", flags=re.MULTILINE)
test_str = ("#TimeMemoryFunctionLocation\n"
"10.0002365832{main}( ).../http.php:0\n"
"20.05691577072Zend\\Mvc\\Application->run( ).../http.php:48\n"
"30.06211677272Zend\\EventManager\\EventManager->triggerEventUntil( ).../Application.php:332\n"
"40.06211677272Zend\\EventManager\\EventManager->triggerListeners( ).../EventManager.php:179\n"
"50.06221677912Zend\\Mvc\\DispatchListener->onDispatch( ).../EventManager.php:322\n"
"60.06261682144WebService\\Controller\\User\\ManageAccountController->dispatch( ).../DispatchListener.php:138\n"
"70.06261682144WebService\\Controller\\User\\ManageAccountController->dispatch( ).../AbstractRestfulController.php:313\n"
"80.06261682464Zend\\EventManager\\EventManager->triggerEventUntil( ).../AbstractController.php:106\n"
"90.06261682464Zend\\EventManager\\EventManager->triggerListeners( ).../EventManager.php:179\n"
"100.06281686864WebService\\Controller\\User\\ManageAccountController->onDispatch( ).../EventManager.php:322\n"
"110.07321939200WebService\\Controller\\User\\ManageAccountController->onDispatch( ).../AbstractController.php:129\n"
"120.07321939232WebService\\Controller\\User\\ManageAccountController->processPostData( ).../AbstractRestfulController.php:429\n"
"130.07341945960WebService\\Controller\\User\\ManageAccountController->create( ).../AbstractController.php:234\n"
"140.08922331024Model\\Model\\UserModel->updateUser( ).../ManageAccountController.php:50\n"
"150.08932331464Model\\Mapper\\UserMapper->updateUserData( ).../UserModel.php:560\n"
"160.08932332744Application\\Database\\Connection->execute( ).../UserMapper.php:475\n"
"170.08942332840Zend\\Db\\Adapter\\Adapter->query( ).../Connection.php:77\n"
"180.08942244472Zend\\Db\\Adapter\\Driver\\Mysqli\\Statement->prepare( ).../Adapter.php:193")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)