using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^b{4}[0-9a-f]{28}$";
string input = @"bbbb00000000000000170d0000306fb6";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}